300字范文,内容丰富有趣,生活中的好帮手!
300字范文 > java起源英文_Abbreviation 英文词组缩写(来源:南阳理工大学ACM)java

java起源英文_Abbreviation 英文词组缩写(来源:南阳理工大学ACM)java

时间:2020-06-06 17:33:55

相关推荐

java起源英文_Abbreviation 英文词组缩写(来源:南阳理工大学ACM)java

As we know, we often use a short sequence of characters in place of some words with a very long name. For example, ACM is an abbreviation of “Association for Computing Machinery”. Now we are using an acronymic method to get the abbreviation. An acronym is generated from a long name by capitalizing the first letter of every word in the name and concatenating them together. There is an exception: some words are ignored when generating the abbreviation. These words( case insensitive) meet the following rules:

1. The common words “and”, “for”, and “the”.

2. The words with length less than 3, such as “a”, “of”, “to”. Your job is to get the abbreviation of a given string by using the acronymic method.

输入

Input starts with an integer T (T <= 100), denoting the number of test cases. Each case contains a line with several words seperated by space(s). The length of each line is less than 100. And you can assume that there is at least one available word for each case.

输出

For each case, print the abbreviation of the word.

样例输入

5

Online Judge

Association for Computer Machinery

Institute of Electrical and Electronics Engineers

The Lord of the Rings

netease

样例输出

OJ

ACM

IEEE

LR

N

import java.util.Scanner;

/**

*

* @author admin

*As we know, we often use a short sequence of characters in place of some words with

*a very long name. For example, ACM is an abbreviation of “Association for Computing

*Machinery”. Now we are using an acronymic method to get the abbreviation. An acronym

*is generated from a long name by capitalizing the first letter of every word in the

*name and concatenating them together. There is an exception: some words are ignored

*when generating the abbreviation. These words( case insensitive) meet the following rules:

*

*1. The common words “and”, “for”, and “the”.

*

*2. The words with length less than 3, such as “a”, “of”, “to”.

*Your job is to get the abbreviation of a given string by using the acronymic method.

*

*输入

*Input starts with an integer T (T <= 100), denoting the number of test cases.

*Each case contains a line with several words seperated by space(s). The length

*of each line is less than 100. And you can assume that there is at least one

*available word for each case.

*输出

*For each case, print the abbreviation of the word.

*实例:

*输入:

*5

*Online Judge

*Association for Computer Machinery

*Institute of Electrical and Electronics Engineers

*The Lord of the Rings

*netease

*输出:

*OJ

*ACM

*IEEE

*LR

*N

*/

public class Abbreviation {

public static void main(String[] args) {

Scanner input=new Scanner(System.in);

int num=Integer.valueOf(input.nextLine());

String[] strArr=new String[num];

for (int i = 0; i < strArr.length; i++) {

strArr[i]=input.nextLine();

}

input.close();

for (int i = 0; i < strArr.length; i++) {

computer(strArr[i]);

}

}

public static void computer(String str)

{

String[] word=str.split(" ");

String tempStr="";

for (int i = 0; i < word.length; i++) {

tempStr+=getWord(word[i]);

}

System.out.println(tempStr);

}

public static String getWord(String str)

{

if(str.length()<3||"and".equals(str)||"for".equals(str)||

"the".equals(str)||"And".equals(str)||"For".equals(str)||"The".equals(str))

{

return"";

}

return str.substring(0, 1).toUpperCase();

}

}

本内容不代表本网观点和政治立场,如有侵犯你的权益请联系我们处理。
网友评论
网友评论仅供其表达个人看法,并不表明网站立场。
相关阅读
南阳理工ACM111

南阳理工ACM111

2023-03-18

南阳理工acm

南阳理工acm

2019-08-02

矩形嵌套 南阳理工ACM

矩形嵌套 南阳理工ACM

2022-08-20

南阳理工ACM(题目56)

南阳理工ACM(题目56)

2022-06-11